// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"D:\/\(!\)PLAYING\/(.*.mp3)").unwrap();
let string = "D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
";
let substitution = "C:\\\\Music\\\\(!)PLAYING\\\\";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}