package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`D:\/\(!\)PLAYING\/(.*.mp3)`)
var str = []byte(`D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
`)
var substitution = []byte("C:\\Music\\(!)PLAYING\\")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}