$re = '/D:\/\(!\)PLAYING\/(.*.mp3)/';
$str = 'D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
';
$subst = "C:\\Music\\(!)PLAYING\\";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;