import Foundation
let pattern = #"D:\/\(!\)PLAYING\/(.*.mp3)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
D:/(!)PLAYING/157490069/c8732d4/file_name.mp3
D:/(!)PLAYING/123123/2d4/file_name.mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"C:\\Music\\(!)PLAYING\\"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}