# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"D:\/\(!\)PLAYING\/(.*.mp3)"
test_str = ("D:/(!)PLAYING/157490069/c8732d4/file_name.mp3\n"
"D:/(!)PLAYING/123123/2d4/file_name.mp3\n")
subst = "C:\\\\Music\\\\(!)PLAYING\\\\"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.