# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|render\(')[^':]*\K:+/\//gm;t' <<< "render('MyBundle:Default:index.html.twig')
or render('MyBundle::Default::index.html.twig')"