import re
regex = re.compile(r"(?:\G(?!^)|render\(')[^':]*\K:+", flags=re.MULTILINE)
test_str = ("render('MyBundle:Default:index.html.twig')\n"
"or render('MyBundle::Default::index.html.twig')")
subst = "/"
result = regex.sub(subst, test_str)
if result:
print(result)