#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ "
Local $sString = "var" & @CRLF & _
" S : string;" & @CRLF & _
"begin" & @CRLF & _
" S := S" & @CRLF & _
" + GF + MT('TeFreezNrGes') + GF + TZ" & @CRLF & _
" + GF + MT('TeFreezNrTeil') + GF + TZ" & @CRLF & _
" + GF + MT('TeZeitVonS') + ' [s]' + GF + TZ; "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")