using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ ";
string input = @"var
S : string;
begin
S := S
+ GF + MT('TeFreezNrGes') + GF + TZ
+ GF + MT('TeFreezNrTeil') + GF + TZ
+ GF + MT('TeZeitVonS') + ' [s]' + GF + TZ; ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}