import Foundation
let pattern = #"\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ "#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
var
S : string;
begin
S := S
+ GF + MT('TeFreezNrGes') + GF + TZ
+ GF + MT('TeFreezNrTeil') + GF + TZ
+ GF + MT('TeZeitVonS') + ' [s]' + GF + TZ;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)