import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*GF\\s*[+]\\s*(.+\\S)\\s*[+]\\s*GF\\s*[+]\\s*TZ ";
final String string = "var\n"
+ " S : string;\n"
+ "begin\n"
+ " S := S\n"
+ " + GF + MT('TeFreezNrGes') + GF + TZ\n"
+ " + GF + MT('TeFreezNrTeil') + GF + TZ\n"
+ " + GF + MT('TeZeitVonS') + ' [s]' + GF + TZ; ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}