re = /\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ /
str = 'var
S : string;
begin
S := S
+ GF + MT(\'TeFreezNrGes\') + GF + TZ
+ GF + MT(\'TeFreezNrTeil\') + GF + TZ
+ GF + MT(\'TeZeitVonS\') + \' [s]\' + GF + TZ; '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end