package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ `)
var str = `var
S : string;
begin
S := S
+ GF + MT('TeFreezNrGes') + GF + TZ
+ GF + MT('TeFreezNrTeil') + GF + TZ
+ GF + MT('TeZeitVonS') + ' [s]' + GF + TZ; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}