$re = '/\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ /';
$str = 'var
S : string;
begin
S := S
+ GF + MT(\'TeFreezNrGes\') + GF + TZ
+ GF + MT(\'TeFreezNrTeil\') + GF + TZ
+ GF + MT(\'TeZeitVonS\') + \' [s]\' + GF + TZ; ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);