const regex = /\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*GF\\s*[+]\\s*(.+\\S)\\s*[+]\\s*GF\\s*[+]\\s*TZ ', 'g')
const str = `var
S : string;
begin
S := S
+ GF + MT('TeFreezNrGes') + GF + TZ
+ GF + MT('TeFreezNrTeil') + GF + TZ
+ GF + MT('TeZeitVonS') + ' [s]' + GF + TZ; `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}