// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*GF\s*[+]\s*(.+\S)\s*[+]\s*GF\s*[+]\s*TZ ").unwrap();
let string = "var
S : string;
begin
S := S
+ GF + MT('TeFreezNrGes') + GF + TZ
+ GF + MT('TeFreezNrTeil') + GF + TZ
+ GF + MT('TeZeitVonS') + ' [s]' + GF + TZ; ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}