# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(coffee|jsx|marko.js)//g;t' <<< "hello1.coffee
hello2.jsx
hello3.marko.js
hello4.marko
hello5.js"