using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(coffee|jsx|marko.js)";
string substitution = @"";
string input = @"hello1.coffee
hello2.jsx
hello3.marko.js
hello4.marko
hello5.js";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}