import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(coffee|jsx|marko.js)";
final String string = "hello1.coffee\n"
+ "hello2.jsx\n"
+ "hello3.marko.js\n"
+ "hello4.marko\n"
+ "hello5.js";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}