import Foundation
let pattern = #"\.(coffee|jsx|marko.js)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
hello1.coffee
hello2.jsx
hello3.marko.js
hello4.marko
hello5.js
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)