#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.(coffee|jsx|marko.js)"
Local $sString = "hello1.coffee" & @CRLF & _
"hello2.jsx" & @CRLF & _
"hello3.marko.js" & @CRLF & _
"hello4.marko" & @CRLF & _
"hello5.js"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)