$re = '/\.(coffee|jsx|marko.js)/';
$str = 'hello1.coffee
hello2.jsx
hello3.marko.js
hello4.marko
hello5.js';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;