// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.(coffee|jsx|marko.js)").unwrap();
let string = "hello1.coffee
hello2.jsx
hello3.marko.js
hello4.marko
hello5.js";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}