const regex = /\.(coffee|jsx|marko.js)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(coffee|jsx|marko.js)', 'g')
const str = `hello1.coffee
hello2.jsx
hello3.marko.js
hello4.marko
hello5.js`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);