package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bword\w*`)
var str = `wording worder got worded. word!`
var substitution = "<deleted>"
fmt.Println(re.ReplaceAllString(str, substitution))
}