import Foundation
let pattern = #"\bword\w*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"wording worder got worded. word!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<deleted>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)