re = /\bword\w*/m
str = 'wording worder got worded. word!'
subst = '<deleted>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result