// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bword\w*").unwrap();
let string = "wording worder got worded. word!";
let substitution = "<deleted>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}