$re = '/\bword\w*/m';
$str = 'wording worder got worded. word!';
$subst = "<deleted>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;