const regex = /\bword\w*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bword\\w*', 'gm')
const str = `wording worder got worded. word!`;
const subst = `<deleted>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);