import re
regex = re.compile(r"\bword\w*", flags=re.MULTILINE)
test_str = "wording worder got worded. word!"
subst = "<deleted>"
result = regex.sub(subst, test_str)
if result:
print(result)