# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[!?.]+(?=$|\s)//g;t' <<< "This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!"