import Foundation
let pattern = #"[!?.]+(?=$|\s)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)