using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[!?.]+(?=$|\s)";
string substitution = @"";
string input = @"This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}