use strict;
my $str = 'This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!';
my $regex = qr/[!?.]+(?=$|\s)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";