re = /[!?.]+(?=$|\s)/
str = 'This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result