import re
regex = re.compile(r"[!?.]+(?=$|\s)")
test_str = "This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)