#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[!?.]+(?=$|\s)"
Local $sString = "This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)