const regex = /[!?.]+(?=$|\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[!?.]+(?=$|\\s)', 'g')
const str = `This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);