$re = '/[!?.]+(?=$|\s)/';
$str = 'This is the f!!rst sentence! Is this the second one? The third sentence is here... And the fourth one!!';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;