const regex = /^(.{10}).*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{10}).*$', 'mg')
const str = `this is sample test
I am from australia
I am from India`;
const subst = `\1...`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);