// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.{10}).*$").unwrap();
let string = "this is sample test
I am from australia
I am from India";
let substitution = "\\1...";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}