re = /^(.{10}).*$/m
str = 'this is sample test
I am from australia
I am from India'
subst = '\\1...'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result