use strict;
my $str = 'this is sample test
I am from australia
I am from India';
my $regex = qr/^(.{10}).*$/mp;
my $subst = '\\1...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";