import Foundation
let pattern = #"^(.{10}).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is sample test
I am from australia
I am from India
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1..."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)