#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+\([^$]*?\)"
Local $sString = "I need a Regular Expression that can match the words that are methods, for example:" & @CRLF & _
"" & @CRLF & _
"Project.name.toUpper().toBase64()" & @CRLF & _
"" & @CRLF & _
"matches: toUpper() and toBase64()" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"Project.name.toLower(1)" & @CRLF & _
"" & @CRLF & _
"matches: toLower(1)" & @CRLF & _
"" & @CRLF & _
"I already have this but it only matches the first found (toUpper()):" & @CRLF & _
"" & @CRLF & _
"Pattern patternParenthesis = Pattern.compile("\\(([^)]+)*[)()]*");"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")