re = /\w+\([^$]*?\)/m
str = 'I need a Regular Expression that can match the words that are methods, for example:
Project.name.toUpper().toBase64()
matches: toUpper() and toBase64()
or
Project.name.toLower(1)
matches: toLower(1)
I already have this but it only matches the first found (toUpper()):
Pattern patternParenthesis = Pattern.compile("\\\\(([^)]+)*[)()]*");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end