const regex = /\w+\([^$]*?\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+\\([^$]*?\\)', 'gm')
const str = `I need a Regular Expression that can match the words that are methods, for example:
Project.name.toUpper().toBase64()
matches: toUpper() and toBase64()
or
Project.name.toLower(1)
matches: toLower(1)
I already have this but it only matches the first found (toUpper()):
Pattern patternParenthesis = Pattern.compile("\\\\(([^)]+)*[)()]*");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}