import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\([^$]*?\\)";
final String string = "I need a Regular Expression that can match the words that are methods, for example:\n\n"
+ "Project.name.toUpper().toBase64()\n\n"
+ "matches: toUpper() and toBase64()\n\n"
+ "or\n\n"
+ "Project.name.toLower(1)\n\n"
+ "matches: toLower(1)\n\n"
+ "I already have this but it only matches the first found (toUpper()):\n\n"
+ "Pattern patternParenthesis = Pattern.compile(\"\\\\(([^)]+)*[)()]*\");";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}