using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\([^$]*?\)";
string input = @"I need a Regular Expression that can match the words that are methods, for example:
Project.name.toUpper().toBase64()
matches: toUpper() and toBase64()
or
Project.name.toLower(1)
matches: toLower(1)
I already have this but it only matches the first found (toUpper()):
Pattern patternParenthesis = Pattern.compile(""\\(([^)]+)*[)()]*"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}